Waiting for approval from Apple
Incident Report for Routii
Resolved
This incident has been resolved.
Posted Jun 15, 2022 - 16:49 UTC
Identified
We are looking into the issue, that Apple did not approve our latest changes.
Posted Jun 14, 2022 - 18:00 UTC
This incident affected: Routii for Iphone.